Welcome to the new Diaspora forums, please let us know if you see anything broken! Notice: Some users may need to reupload their avatars due to an issue during forum setup!

Space Combat 2 Test Server - Issue Reporting Thread

LtBrandonLtBrandon Posts: 506Registered, Administrator
Please report any issues you run into while playing on the test server here.
This is a block of text that can be added to posts you make. There is a 255 character limit.

Lλmbdλ: donations for coding the space future of diaspora :>

Get your extra long EVE trial here!

Comments

  • Randy SavageRandy Savage Posts: 5Registered
    422JW8r.png

    Issue with the HUD

    Aspect ratio: 16:10
    Resolution 1366:768
  • Randy SavageRandy Savage Posts: 5Registered
    Datch04 killed a core owned by Datch04

    [ERROR] gamemodes/spacebuild3/entities/effects/sc_subxpl_capitalcrit.lua:109: Tried to use a NULL entity!
    1. LocalToWorld - [C]:-1
    2. unknown - gamemodes/spacebuild3/entities/effects/sc_subxpl_capitalcrit.lua:109

    Timer Failed! [Simple][@gamemodes/spacebuild3/entities/effects/sc_subxpl_capitalcrit.lua (line 108)]

    [ERROR] gamemodes/spacebuild3/entities/effects/sc_subxpl_capitalcrit.lua:127: Tried to use a NULL entity!
    1. LocalToWorld - [C]:-1
    2. unknown - gamemodes/spacebuild3/entities/effects/sc_subxpl_capitalcrit.lua:127

    Timer Failed! [Simple][@gamemodes/spacebuild3/entities/effects/sc_subxpl_capitalcrit.lua (line 126)]

    #And then a couple of secounds later


    [ERROR] gamemodes/spacebuild3/entities/effects/sc_subxpl_capitalcrit.lua:40: Tried to use a NULL entity!
    1. LocalToWorld - [C]:-1
    2. unknown - gamemodes/spacebuild3/entities/effects/sc_subxpl_capitalcrit.lua:40

    Timer Failed! [Simple][@gamemodes/spacebuild3/entities/effects/sc_subxpl_capitalcrit.lua (line 34)]
  • Randy SavageRandy Savage Posts: 5Registered
    I noticed a problem with my hydrogen production on my ship. My setup was an antimatter reactor that used 2880 u/m hydrogen, and an antimatter creator that used 2250 u/s of hydrogen. That meant a total usage of 2298 u/s of hydrogen.
    Now, I wired up my water splitter to create a total of 2500 u/s hydrogen. That means a total surplus of 202 u/s hydrogen. But, instead of a surplus of 202 u/s, the total amount of hydrogen in my tanks hovered around 1%, very rarely going up to 2% before being promptly used up. So I made some experiments. First I measured the amount of time it would take for a water splitter to fill a resource tank with oxygen and hydrogen respectively, and compared them to how long it would take theoreticly. I got these results:
    Theoretical Hydrogen Production: 2.45 k/s
    Actual Hydrogen Production: 1.79 k/s
    Theoretical Oxygen Production: 1.22 k/s
    Actual Oxygen Production: 0.889 k/s
    Now it is worth mentioning that the experiments were on a small scale, so I would like to recreate the tests at a bigger scale.

    After getting these results I tried to experiment with my afformentioned ship problem. I cranked up my water splitter to create a whopping 4500 u/s of hydrogen, and 2250 u/s oxygen. Theoreticly creating a 2202 u/s hydrogen surplus. I allowed it to fill up my tanks with no other reactors/producers interfering. After filling up my tanks with hydrogen, I turned on my antimatter creator and the antimatter reactor and observed my (single) hydrogen resource tank to go from 100% to 90% in one minute. In this case it would mean a loss of about 10 000 u of hydrogen in 1 minute. That means that instead of getting the 2202 u/s hydrogen surplus I WAS PROMISED... I got a 166 u/s hydrogen deficit. The only way this would make sense is if the oxygen production and hydrogen production were switched somehow. But I don't think thats the case, since my earlier experiment did not indicate that.
  • Randy SavageRandy Savage Posts: 5Registered
    Changing the material of a turret base gives this error:

    [ERROR] gamemodes/spacebuild3/entities/entities/sc_turret.lua:734: Tried to use a NULL entity!
    1. GetColor - [C]:-1
    2. CheckMaterials - gamemodes/spacebuild3/entities/entities/sc_turret.lua:734
    3. unknown - gamemodes/spacebuild3/entities/entities/sc_turret.lua:752
  • Gamecube64Gamecube64 Posts: 3Registered
    LS Core Links To Ship Core But Still Says Failed To Connect And Once Active You Can't Turn It Off.
  • elwolf6elwolf6 Posts: 7Registered
    422JW8r.png

    Issue with the HUD

    Aspect ratio: 16:10
    Resolution 1366:768

    that's been happening forever you just click the name of a person and it fixes itself
  • njits23njits23 Posts: 8Registered
    It's impossible to run graviton reactors on any of the coolants except maybe anubium. The antihydrogen outputs are also significantly low, it makes 150 antihydrogen per 30, where an auxiliary antimatter reactor uses 1800 antihydrogen per 60, and therefore 900 per 30. meaning 12 cycles of the graviton for one cycle of an antimatter reactor. So 6 minutes of waiting around for one minute of antimatter power, which seems a tad excessive.
    Ring ring ring ring ring ring ring banana phone!
  • Gamecube64Gamecube64 Posts: 3Registered
    Reactors Don't Have Explosion Effect Or Sound.
  • elwolf6elwolf6 Posts: 7Registered
    Bug report uh i don't have enough coolant i turn reactor on because RDA scientists are smart, reactor go boom
    Moisture Vaporator multiplier goes down to like -80 from 40
    https://i.imgur.com/8f6PgGH.png
  • elwolf6elwolf6 Posts: 7Registered
    leave some battleship class solars on a battleship with like 23mil cap for 1 minute and its at full cap
  • elwolf6elwolf6 Posts: 7Registered
    spawning in a ship makes the generators sometimes go to FAIL but respawning fixes its anoying pls fix
  • Randy SavageRandy Savage Posts: 5Registered
    Lasers are broken. Instead of reloading the entire magazine in a cycle, it only reloads one charge at a time. Also, the laser beam weapon seems to blow its wad in 1 secound instead of 10.

Leave a Comment

bolditalicunderlinestrikecodeimageurlquotespoiler
Drop image/file